znaczacy > comp.os.* > comp.os.ms-windows.winnt

piotr (09.05.2004, 13:35)
"
500 invalid PORT Command" taki komunikat mam laczac z sie FTP przez total
commandera w czym problem dodam ze z innej siedzi mi on dziala, ftp to
Windowsowy FTP wbudowany w IIS, laczac sie z innej sieci moge spokojnie sie
zalogowac

w czym problem czy to problem z ustawianiami serwera czy tez moze problem
mojej lokalnej sieci?

pozdrawiam
Błażej Kucharczyk (09.05.2004, 13:41)
W dniu 2004-05-09 13:35 użytkownik piotr napisal/a:
> "
> 500 invalid PORT Command" taki komunikat mam laczac z sie FTP przez total
> commandera w czym problem dodam ze z innej siedzi mi on dziala, ftp to
> Windowsowy FTP wbudowany w IIS, laczac sie z innej sieci moge spokojnie sie
> zalogowac
> w czym problem czy to problem z ustawianiami serwera czy tez moze problem
> mojej lokalnej sieci?

Też mam coś takiego, jak się łącze z webpark.pl. Poradziłem sobie
ustawiając proxy, ale nie wiem dlaczego tak się dzieje i sam jestem
ciekawy o co chodzi.
jerzy szczudłowski (09.05.2004, 13:56)
Błażej Kucharczyk wrote:
>> w czym problem czy to problem z ustawianiami serwera czy tez moze problem
>> mojej lokalnej sieci?

> Też mam coś takiego, jak się łącze z webpark.pl. Poradziłem sobie
> ustawiając proxy, ale nie wiem dlaczego tak się dzieje i sam jestem
> ciekawy o co chodzi.


O tryb czynny (active), bierny (passive) i NAT.
Radosław Sokół (09.05.2004, 14:16)
piotr wrote:
> 500 invalid PORT Command" taki komunikat mam laczac z sie FTP przez total
> commandera w czym problem dodam ze z innej siedzi mi on dziala, ftp to
> Windowsowy FTP wbudowany w IIS, laczac sie z innej sieci moge spokojnie sie
> zalogowac


Pewnie próbujesz się logować w trybie aktywnym z sieci
znajdującej się za NATem. A próba nawiązania połączenia z
IP pochodzącym z pul prywatnych jest z góry skazana na
niepowodzenie ;)

Przełącz klienta FTP w tryb pasywny lub użyj lepszego NATa.
piotr (09.05.2004, 14:25)
> Przełącz klienta FTP w tryb pasywny lub użyj lepszego NATa.

tzn.?

przelaczylem w tryb pasywny klienta i tez nic najpierw pojawi sie komunikat
227 entering passive mode .....

i po jakies minucie pojawia sie komunikat 500 invalid PORT Command

co mam zrobic aby mi to zadzilalo, moze jakies zmieny na ftp albo firewallu
piotr (09.05.2004, 14:32)
co mam zle na serwerz a moze firewallu ze nie moge sie dolaczyc w trybie
pasive mode do ftp, ftp to wbudowany ftp windowsowy

pojawia sie komunikat 500 invalid port command lacze sie z innej sieci,
lokalnie i w z innych sieci dziala
piotr (09.05.2004, 14:41)
moze dlatego ze na jednym serwerz jest www i ftp?
Radosław Sokół (09.05.2004, 15:32)
piotr wrote:
> przelaczylem w tryb pasywny klienta i tez nic najpierw pojawi sie komunikat
> 227 entering passive mode .....
> i po jakies minucie pojawia sie komunikat 500 invalid PORT Command


Spróbuj innego klienta. W trybie pasywnym polecenie PORT
nie ma prawa być wysłane. Poza tym sprawdź, czy przypadkiem
na serwerze nie jest włączony źle skonfigurowany firewall,
bo wtedy tryb pasywny z kolei przez serwer nie będzie
działać.

> moze dlatego ze na jednym serwerz jest www i ftp?


Nie.
Radosław Popławski (09.05.2004, 15:45)
Sun, 9 May 2004 14:25:56 +0200, w <c7l85f$a1h$1>, "piotr"
<piotr2_.s> napisał(-a):

> > Przełącz klienta FTP w tryb pasywny lub użyj lepszego NATa.

> tzn.?
> przelaczylem w tryb pasywny klienta i tez nic najpierw pojawi sie komunikat
> 227 entering passive mode .....
> i po jakies minucie pojawia sie komunikat 500 invalid PORT Command
> co mam zrobic aby mi to zadzilalo, moze jakies zmieny na ftp albo firewallu


Widać serwer ftp jest fatalnie skonfigurowany i nie zezwala na tryb pasywny.
Zgłoś to administrtorowi.
Radosław Popławski (09.05.2004, 16:16)
Sun, 09 May 2004 15:32:54 +0200, w <2004050913305300>, Radosław
Sokół <rsokol> napisał(-a):

> piotr wrote:
> > przelaczylem w tryb pasywny klienta i tez nic najpierw pojawi sie komunikat
> > 227 entering passive mode .....
> > i po jakies minucie pojawia sie komunikat 500 invalid PORT Command

> Spróbuj innego klienta. W trybie pasywnym polecenie PORT
> nie ma prawa być wysłane. Poza tym sprawdź, czy przypadkiem


On ma zapewne Total Commander. TC, gdy nie uda się nawiązać połączenia w
passive, przechodzi na active i stąd Invalid Port...

A przyczyna jest taka jak napisałem wcześniej.
piotr (09.05.2004, 17:17)
Widać serwer ftp jest fatalnie skonfigurowany i nie zezwala na tryb pasywny.
Zgłoś to administrtorowi.

nie do konca tak, bo z innych sieci dziala i tak i tak
Radosław Popławski (09.05.2004, 17:30)
Sun, 9 May 2004 17:17:20 +0200, w <c7li2q$sd6$1>, "piotr"
<piotr2_.s> napisał(-a):

>> Widać serwer ftp jest fatalnie skonfigurowany i nie zezwala na tryb pasywny.
>> Zgłoś to administrtorowi.

> nie do konca tak, bo z innych sieci dziala i tak i tak


Widać z innych sieci nie łączysz się przez NAT.

PS. Skonfiguruj sobie czytnik albo nie pisz na newsy.
piotr (09.05.2004, 18:16)
PS. Skonfiguruj sobie czytnik albo nie pisz na newsy.

jak mam Twoim zdaniem skonfigurowac czytnik, jesli mowisz ze cos jest zle
skonfigurowane Twoim zdaniem to tez powiedz dlaczego?

--------czlowieku idz na spacer bedziesz szczesliwszy
piotr (09.05.2004, 18:24)
Ty tez nie pisz na newsy jesli masz tak pisac a nie pomagac

zapomniala krowa....
Radosław Popławski (09.05.2004, 18:28)
Sun, 9 May 2004 18:16:15 +0200, w <c7lll9$g3u$1>, "piotr"
<piotr2_.s> napisał(-a):

> PS. Skonfiguruj sobie czytnik albo nie pisz na newsy.
> jak mam Twoim zdaniem skonfigurowac czytnik, jesli mowisz ze cos jest zle
> skonfigurowane Twoim zdaniem to tez powiedz dlaczego?
> --------czlowieku idz na spacer bedziesz szczesliwszy


1. Cytuj znakami > wypowiedź tych, którym odpowiadasz.
2. Nie masz w nagłówkach oznaczenia charsetu ISO8859-2 -- to też zrób.

Podobne wątki