znaczacy > comp.* > comp.sieci

Colnet (10.05.2019, 15:00)
Linux Mint 19.1 64 bit. Mam na laptopie taki Linux a w nim karte Wi-Fi: Intel Corporation PRO/Wireless 3945ABG [Golan].
Karta poczawszy od dystrybucji Linux Mint- 18.1 do terazniejszej - 19.1 - jest niestabilna i rozlacza sie co kilkanascie/kilkadziesiat minut z intermetem. Zjawiska tego nie ma pod linuxMint 17.3. Chce "wydlubac" driver wi-fi z tej dystrybucji 17.3 i podpiac go jako driver wi-fi w tej dystrybucji 19.1 - nie wiem jednak jaki to plik/pliki i jak to zrobic. Prosze p pmoc w temacie.
Jacek Maciejewski (10.05.2019, 15:15)
Dnia Fri, 10 May 2019 06:00:58 -0700 (PDT), Colnet napisal(a):

> Intel Corporation PRO/Wireless 3945ABG


Polecenie:
inxi -n
pokaze ci jaki driver masz obecnie. A IMO powinienes miec driver
non-free iwlwifi. Tu masz linka jak go zainstalowac:
Colnet (10.05.2019, 19:10)
W dniu piatek, 10 maja 2019 13:15:05 UTC uzytkownik Jacek Maciejewski napisal:
[..]
> Polecenie:
> inxi -n
> pokaze ci jaki driver masz obecnie. A IMO powinienes miec driver
> non-free iwlwifi. Tu masz linka jak go zainstalowac:
> [..]


Dziekuje za odpowiedz. Ten opis dotyczy starych Debianow, ale mimo staralemsie to zrobic. Wiec polecenie: deb jessie main contrib non-free
na Linux MInt sie nie wykonuje i daje taki komunikat :

Command 'deb' not found, did you mean:
command 'dex' from deb dex
[..]nizej inne podobne

Drugie z polecen :
apt-get update && apt-get install firmware-iwlwifi

daje taki komunikat :
Unable to locate package firmware-iwlwifi

Wobec niepowodzenia na tej stronie postanowiem podmienic driver 19.1 na 17.3
a bylo to tak :
modprobe -r iwl3945
potem podmiana przy pomocy MC tego pliku na plik z 17.3, a potem
modprobe -a iwl3945
Rezultat ? Utrata sieci w ogole - pisze z wirtualnego Linux Mint (brak polskich znakow). Modprobe napisal ze jakies bledy , nie rozpoznaje symboli etc.. Postanowilem wiec przywrocic driver 19.1 , ale modprobe napisal to samo co dla drivera 17.3 (bledy i nie rozpoznaje symboli)
Poki co jestem w internecie na tym "virtualu" bo inaczej "sie nie da".Jeslisprawy nie da sie zrobic w ciagu 3-4 dni to zainstaluje Linux Mint 17.3 - ten pracuje stabilnie I nie ma “keyring’a” ktory nie pytany o zgode podmienia hasla I “hasluje” inne programy. O wpasowanie tego programu do Linux Mint podejrzewam V-ta kolumne M$ ktora chyba udalo mu sie osadzic w Linux Mint, zeby uczynic Linux Mint jeszczebardziej upierdliwym niz jest.
Jacek Maciejewski (10.05.2019, 19:36)
Dnia Fri, 10 May 2019 10:10:39 -0700 (PDT), Colnet napisal(a):

> W dniu piatek, 10 maja 2019 13:15:05 UTC uzytkownik Jacek Maciejewski napisal:
> [..]
> [..]
> Dziekuje za odpowiedz. Ten opis dotyczy starych Debianow, ale mimo staralem sie to zrobic. Wiec polecenie: deb jessie main contrib non-free
> na Linux MInt sie nie wykonuje i daje taki komunikat :
> Command 'deb' not found, did you mean:
> command 'dex' from deb dex
> [..]nizej inne podobne

To polecenie dodaje repozytorium do mechanizmu uzywanego przez apt-get.
Zamiast uzywac programu deb którego istotnie w 19 nie ma, dodaj
repozytorium recznie w synapticu - Ustawienia>Repozytoria>Dodaj. Po
dodaniu oczywiscie musisz uaktualnic baze danych o pakietach o obecne w
tym repo (polecenie Edycja>Odswiez inf. o pakietach)
> Drugie z polecen :
> apt-get update && apt-get install firmware-iwlwifi
> daje taki komunikat :
> Unable to locate package firmware-iwlwifi

Nic dziwnego, zapewne w istniejacych repo nie ma takiego pakietu. Jak
dodasz nowe repo powinien sie znalezc.
> Wobec niepowodzenia na tej stronie postanowiem podmienic driver 19.1 na 17.3
> a bylo to tak :
> modprobe -r iwl3945
> potem podmiana przy pomocy MC tego pliku na plik z 17.3, a potem
> modprobe -a iwl3945
> Rezultat ? Utrata sieci w ogole - pisze z wirtualnego Linux Mint (brak polskich znakow). Modprobe napisal ze jakies bledy , nie rozpoznaje symboli etc. Postanowilem wiec przywrocic driver 19.1 , ale modprobe napisal to samo co dla drivera 17.3 (bledy i nie rozpoznaje symboli)
> Poki co jestem w internecie na tym "virtualu" bo inaczej "sie nie da".Jesli sprawy nie da sie zrobic w ciagu 3-4 dni to zainstaluje Linux Mint 17.3 - ten pracuje stabilnie I nie ma “keyring’a” ktory nie pytany o zgode podmienia hasla I “hasluje” inne programy. O wpasowanie tego programu do Linux Mint podejrzewam V-ta kolumne M$ ktora chyba udalo mu sie osadzic w Linux Mint, zeby uczynic Linux Mint jeszcze bardziej upierdliwym niz jest.

Bieda, namieszales a ja nie wiem jak odkrecic :) Jak zamieniles plik
(pytanie czy rzeczywiscie?) to zamien z powrotem. Niestety, malo sie
znam na modprobe, depmod czy podobnych zakleciach.
Jacek Maciejewski (10.05.2019, 19:38)
Dnia Fri, 10 May 2019 10:10:39 -0700 (PDT), Colnet napisal(a):

> ten pracuje stabilnie I nie ma “keyring’a” ktory nie pytany o zgode podmienia hasla I “hasluje” inne programy


Nic takiego nie zauwazylem. Hasla do czego niby?
Jacek Maciejewski (10.05.2019, 19:39)
Dnia Fri, 10 May 2019 10:10:39 -0700 (PDT), Colnet napisal(a):

> W dniu piatek, 10 maja 2019 13:15:05 UTC uzytkownik Jacek Maciejewski napisal:
> [..]
> [..]
> Dziekuje za odpowiedz. Ten opis dotyczy starych Debianow, ale mimo staralem sie to zrobic. Wiec polecenie: deb jessie main contrib non-free
> na Linux MInt sie nie wykonuje i daje taki komunikat :
> Command 'deb' not found, did you mean:
> command 'dex' from deb dex
> [..]nizej inne podobne

To polecenie dodaje repozytorium do mechanizmu uzywanego przez apt-get.
Zamiast uzywac programu deb którego istotnie w 19 nie ma, dodaj
repozytorium recznie w synapticu - Ustawienia>Repozytoria>Dodaj. Po
dodaniu oczywiscie musisz uaktualnic baze danych o pakietach o obecne w
tym repo (polecenie Edycja>Odswiez inf. o pakietach)
PS. Nie zauwazylem ze drugie polecenie tez odswieza (apt-get update)
> Drugie z polecen :
> apt-get update && apt-get install firmware-iwlwifi
> daje taki komunikat :
> Unable to locate package firmware-iwlwifi

Nic dziwnego, zapewne w istniejacych repo nie ma takiego pakietu. Jak
dodasz nowe repo powinien sie znalezc.
> Wobec niepowodzenia na tej stronie postanowiem podmienic driver 19.1 na 17.3
> a bylo to tak :
> modprobe -r iwl3945
> potem podmiana przy pomocy MC tego pliku na plik z 17.3, a potem
> modprobe -a iwl3945
> Rezultat ? Utrata sieci w ogole - pisze z wirtualnego Linux Mint (brak polskich znakow). Modprobe napisal ze jakies bledy , nie rozpoznaje symboli etc. Postanowilem wiec przywrocic driver 19.1 , ale modprobe napisal to samo co dla drivera 17.3 (bledy i nie rozpoznaje symboli)
> Poki co jestem w internecie na tym "virtualu" bo inaczej "sie nie da".Jesli sprawy nie da sie zrobic w ciagu 3-4 dni to zainstaluje Linux Mint 17.3 - ten pracuje stabilnie I nie ma “keyring’a” ktory nie pytany o zgode podmienia hasla I “hasluje” inne programy. O wpasowanie tego programu do Linux Mint podejrzewam V-ta kolumne M$ ktora chyba udalo mu sie osadzic w Linux Mint, zeby uczynic Linux Mint jeszcze bardziej upierdliwym niz jest.

Bieda, namieszales a ja nie wiem jak odkrecic :) Jak zamieniles plik
(pytanie czy rzeczywiscie?) to zamien z powrotem. Niestety, malo sie
znam na modprobe, depmod czy podobnych zakleciach.
Colnet (10.05.2019, 20:45)
OK. Jeszcze dzis zainstaluje mint 19.1 bo mimpo ze plik drivera przywroconyi wydane polecenie modprobe -a iwl3945 - sieci dalej niema. Ten linux swiezy jest i malo na nim zainstalowane i prac malo - wiec bedzie szybciej jak naprawa tej sieci. Odezwe sie jutro poznym popoludniem.
Colnet (11.05.2019, 20:59)
Troche pochopnie powiedzialem ze bede póznym popoludniem -przepraszam.
Nowy linux Mint 19.1, siec pracuje. Próbowalem dodac repozytorium w : Ustawienia -> Administracja -> zródla oprogramowania - ten link sie wprawdzie dodaje, ale jak wcisne OK zeby odswierzyc bufor to wypisuje mi:
E:The repository 'http://httpredir.debian.org/debian bionic Release' does not have a Release file.
Jacek Maciejewski (11.05.2019, 21:43)
Dnia Sat, 11 May 2019 11:59:29 -0700 (PDT), Colnet napisal(a):

> Troche pochopnie powiedzialem ze bede póznym popoludniem -przepraszam.
> Nowy linux Mint 19.1, siec pracuje. Próbowalem dodac repozytorium w : Ustawienia -> Administracja -> zródla oprogramowania - ten link sie wprawdzie dodaje, ale jak wcisne OK zeby odswierzyc bufor to wypisuje mi:
> E:The repository 'http://httpredir.debian.org/debian bionic Release' does not have a Release file.


1. Mysle sobie ze latwiej by bylo próbowac instalowac driver na linuksie
live. Jak cos sie skitra, to restartujesz i voila.
2. Najwyrazniej repo nie istnieje. Stare wersje sa czesto przesuwane
gdzie indziej.
3. Spróbuj tego repo:


A w ogóle, to popytaj na pl.comp.os.linux. Moze tam ktos bedzie
wiedzial w jakim repo szukac drivera albo podpowie jak szukac.
Jacek Maciejewski (11.05.2019, 21:50)
Dnia Sat, 11 May 2019 11:59:29 -0700 (PDT), Colnet napisal(a):

> Troche pochopnie powiedzialem ze bede póznym popoludniem -przepraszam.
> Nowy linux Mint 19.1, siec pracuje. Próbowalem dodac repozytorium w : Ustawienia -> Administracja -> zródla oprogramowania - ten link sie wprawdzie dodaje, ale jak wcisne OK zeby odswierzyc bufor to wypisuje mi:
> E:The repository 'http://httpredir.debian.org/debian bionic Release' does not have a Release file.


1. Mysle sobie ze latwiej by bylo próbowac instalowac driver na linuksie
live. Jak cos sie skitra, to restartujesz i voila.
2. Najwyrazniej repo nie istnieje. Stare wersje sa czesto przesuwane
gdzie indziej.
3. Spróbuj tego repo:

Lub ten (streth):


A w ogóle, to popytaj na pl.comp.os.linux. Moze tam ktos bedzie
wiedzial w jakim repo szukac drivera albo podpowie jak szukac.
Colnet (11.05.2019, 23:05)
W dniu sobota, 11 maja 2019 20:50:24 UTC+1 uzytkownik Jacek Maciejewski napisal:
[..]
> 3. Spróbuj tego repo:
>
> Lub ten (streth):
>

[..]
OK - za duzo zabiegów i za trudne, a z braku zródel - czasem niemozliwe. Dziekuje Ci za pomoc i poswiecony czas – nie co dzien jest szampan. Odkladamy temat nalepsze czasy - niepotrzebnie ekipa z Mint ruszala ten driver - tamtenz 17.3 stabilnie pracowal, wiec po prostu zainstaluje wersje 17.3 - ja lubie nowinki, ale nie jestem ich fanatykiem.
Jacek Maciejewski (12.05.2019, 12:51)
Dnia Sat, 11 May 2019 14:05:03 -0700 (PDT), Colnet napisal(a):

> W dniu sobota, 11 maja 2019 20:50:24 UTC+1 uzytkownik Jacek Maciejewski napisal:
> [..]
> [..]
> OK - za duzo zabiegów i za trudne, a z braku zródel - czasem niemozliwe. Dziekuje Ci za pomoc i poswiecony czas – nie co dzien jest szampan. Odkladamy temat na lepsze czasy - niepotrzebnie ekipa z Mint ruszala ten driver - tamten z 17.3 stabilnie pracowal, wiec po prostu zainstaluje wersje 17.3 - ja lubie nowinki, ale nie jestem ich fanatykiem.


Moze i odrobilem lekcje za ciebie :) Idz na

Zassij pakiet firmware-iwlwifi_0.43_all.deb
Kliknij i zainstaluj. Potem wykonaj zaklecie:
# modprobe -r iwl3945 iwl4965
# modprobe iwl3945 ; modprobe iwl4965
Mam nadzieje ze zadziala :)
Jacek Maciejewski (12.05.2019, 13:58)
Dnia Sat, 11 May 2019 14:05:03 -0700 (PDT), Colnet napisal(a):

> W dniu sobota, 11 maja 2019 20:50:24 UTC+1 uzytkownik Jacek Maciejewski napisal:
> [..]
> [..]
> OK - za duzo zabiegów i za trudne, a z braku zródel - czasem niemozliwe. Dziekuje Ci za pomoc i poswiecony czas – nie co dzien jest szampan. Odkladamy temat na lepsze czasy - niepotrzebnie ekipa z Mint ruszala ten driver - tamten z 17.3 stabilnie pracowal, wiec po prostu zainstaluje wersje 17.3 - ja lubie nowinki, ale nie jestem ich fanatykiem.


Moze i odrobilem lekcje za ciebie :) Idz na

Zassij pakiet firmware-iwlwifi_0.43_all.deb
Kliknij i zainstaluj. Potem wykonaj zaklecie:
# modprobe -r iwl3945 iwl4965
# modprobe iwl3945 ; modprobe iwl4965
Mam nadzieje ze zadziala :)

PS.
Zglosilem temat na grupe o linuksie, pl.comp.os.linux. Zajrzyj tam :)
Wyglada na to ze dalem zla rade co do typu sterownika. Ma byc iwlegacy.
Na stronie która linkuje Alaszewski, jest opisane jak to zrobic.
Jacek Maciejewski (12.05.2019, 14:15)
Dnia Sat, 11 May 2019 14:05:03 -0700 (PDT), Colnet napisal(a):

> W dniu sobota, 11 maja 2019 20:50:24 UTC+1 uzytkownik Jacek Maciejewski napisal:
> [..]
> [..]
> OK - za duzo zabiegów i za trudne, a z braku zródel - czasem niemozliwe. Dziekuje Ci za pomoc i poswiecony czas – nie co dzien jest szampan. Odkladamy temat na lepsze czasy - niepotrzebnie ekipa z Mint ruszala ten driver - tamten z 17.3 stabilnie pracowal, wiec po prostu zainstaluje wersje 17.3 - ja lubie nowinki, ale nie jestem ich fanatykiem.


Moze i odrobilem lekcje za ciebie :) Idz na

Zassij pakiet firmware-iwlwifi_0.43_all.deb
Kliknij i zainstaluj. Potem wykonaj zaklecie:
# modprobe -r iwl3945 iwl4965
# modprobe iwl3945 ; modprobe iwl4965
Mam nadzieje ze zadziala :)

PS.
Zglosilem temat na grupe o linuksie, pl.comp.os.linux. Zajrzyj tam :)
Wyglada na to ze dalem zla rade co do typu sterownika. Ma byc iwlegacy.
Na stronie która linkuje Alaszewski, jest opisane jak to zrobic.

PS2. G... prawda. Alaszewski sie chyba nie wysilil, cos mi w tej
poradzie nie trybi.
Smok Eustachy (26.02.2020, 00:14)
W dniu 10.05.2019 o 15:00, Colnet pisze:
> Linux Mint 19.1 64 bit. Mam na laptopie taki Linux a w nim kartÄ™ Wi-Fi : Intel Corporation PRO/Wireless 3945ABG [Golan].
> Karta począwszy od dystrybucji Linux Mint- 18.1 do terażniejszej - 19.1 - jest niestabilna i rozłącza się co kilkanaście/kilkadziesiąt minut z intermetem. Zjawiska tego nie ma pod linux Mint 17.3. Chcę "wydłubać" driver wi-fi z tej dystrybucji 17.3 i podpiąć go jako driver wi-fi w tej dystrybucji 19.1 - nie wiem jednak jaki to plik/pliki i jak to zrobić. Proszę p pmoc w temacie.

To jądro może być a nie driver

Podobne w±tki