znaczacy > comp.os.* > comp.os.linux.sieci

Marek 'Qrczak' Potocki (27.10.2010, 07:55)
Witam.
Od jakiegoś czasu mam dziwny problem.
Otóż jest sobie serwer DNS (bind 9), który, jak to zwykle miewają DNSy, za
ma zadanie rozgłaszać adresy jakiejś domeny. I robi to. Tylko czasem mu
odbija i w sieci ląduje adres serwera z błędnym numerem IP - obcina
ostatnią cyfrę i zamiast .98 dostaję .9
Efektu chyba nie muszę tłumaczyć. Przekopałem cały serwer i nigdzie w
plikach konfiguracyjnych nie występuje ten błędny adres. Taki błąd potrafi
wyskoczyć raz na dobę, ale rozłazi się. A że pod wskazanym adresem jest
serwer poczty, to bardzo prawdopodobne, że część wiadomości w ogóle nie
dochodzi (a bywa i tak, że ludziki nie mogą sprawdzić skrzynek, bo nie
znaleziono serwera).

Macie może jakieś pomysły czego i gdzie szukać, żeby wyeliminować błąd? Sam
bind był już wymieniony, więc to nie jest kwestia problemu z softem.

Z góry dzięki za sugestie :)
Lemat (27.10.2010, 13:50)
Marek 'Qrczak' Potocki wrote:

[..]
> Macie moze jakies pomysly czego i gdzie szukac, zeby wyeliminowac blad?
> Sam bind byl juz wymieniony, wiec to nie jest kwestia problemu z softem.
> Z góry dzieki za sugestie :)

1) wlacz logowanie
2) sprawdz w logach o co pytaja klienci
3) sprawdz w strefie domeny lokalnej jaki host ma IP z koncówka 9
4) porównaj 2) i 3)
5) sprawdz czy klienci uzywaja twojego i tylko twojego serwera DNS
Lukasz Olesiejuk (28.10.2010, 00:24)
Dnia 27.10.2010 Lemat <#> napisal/a:
> Marek 'Qrczak' Potocki wrote:
> 1) wlacz logowanie
> 2) sprawdz w logach o co pytaja klienci
> 3) sprawdz w strefie domeny lokalnej jaki host ma IP z koncówka 9
> 4) porównaj 2) i 3)
> 5) sprawdz czy klienci uzywaja twojego i tylko twojego serwera DNS


Jeszcze dorzuce pytanie, moze na update zezwalasz?
Marek 'Qrczak' Potocki (04.11.2010, 09:38)
Dnia Wed, 27 Oct 2010 13:50:38 +0200, Lemat napisał(a):

> 1) włącz logowanie
> 2) sprawdź w logach o co pytają klienci
> 3) sprawdź w strefie domeny lokalnej jaki host ma IP z końcówką 9
> 4) porównaj 2) i 3)
> 5) sprawdź czy klienci uzywają twojego i tylko twojego serwera DNS


Witam ponownie. Troszkę poobserwowałem i tak:
w sieci lokalnej problem nie występuje. mój dns odpytany na okoliczność
serwera pocztowego zawsze odpowiada tak jak powinien.
Serwery zapasowe też wygląda, że odpowiadają OK.
Wszystko wskazuje, że błąd powstaje gdzieś w świecie, poza moimi mackami :(

A najgorsze jest to, że przez dwa dni było OK i dziś rano znów błąd
kumplowi wywaliło.
Podobne wątki