znaczacy > comp.os.* > comp.os.linux.sieci

Servant (08.07.2009, 08:03)
ant <ant> napisał(a) w wiadomosci do grupy dyskusyjnej

> obserwuj co sie pojawia
> w pliku log˘w kiedy ten user nobody "zazyna" procka


Ależ on to robi cały czas!
Zauważyłem ciekawą zależność
1. jeżeli nikt nie otwiera plików przez sambę (zalogowanych 3 użytkowników),
to nobody oscyluje w granicach 10%
2. Kiedy ludki otworzą tak z 1000 plików to aktywność 'nobody' wzrasta do 30-
40%
3. Równoczesnie wzrasta obciążenie proca przez demon cupsa (potrafi
przekroczyć 20% choc nikt nie drukuje i kolejki puste)

Myślę, że ta wersja samby jest skopana. Trzeba będzie wrócić do poprzedniej
3.0.xx
ant (09.07.2009, 07:57)
Servant wrote:
> Ależ on to robi cały czas!
> Zauważyłem ciekawą zależność
> 1. jeżeli nikt nie otwiera plików przez sambę (zalogowanych 3 użytkowników),
> to nobody oscyluje w granicach 10%
> 2. Kiedy ludki otworzą tak z 1000 plików to aktywność 'nobody' wzrasta do 30-
> 40%
> 3. Równoczesnie wzrasta obciążenie proca przez demon cupsa (potrafi
> przekroczyć 20% choc nikt nie drukuje i kolejki puste)
> Myślę, że ta wersja samby jest skopana. Trzeba będzie wrócić do poprzedniej
> 3.0.xx


Ja bym wziął jeszcze pod lupę Cupsa. Swego czasu miałem
taki zestaw samba + cups, gdzie cups lubił zdychać
i też siadać na procku. Wymieniłem cupsa na nowszego
i zaczęło działać.

Na końcówkach (domyślam się Windows) włączone masz
"automatycznego wyszukiwanie folderów sieciowych i drukarek"
czy jakoś tak? Ja to zawsze wyłączam na końcówkach.
To może być jakiś pośredni powód zamęczania Cupsa...
Sebastian Sawicki (09.07.2009, 11:11)
Servant said the following on 07.07.2009 14:24:
> Oto wynik polecenia top -u nobody
> PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
> 29575 nobody 20 0 14200 4312 3020 R 23.3 1.7 1:05.09 smbd


> Co można z tym zrobić?


strace -p 29575

S.
Olek (12.07.2009, 14:10)
Servant wrote:
> Bywa, że przekracza i 50%.


A używasz nfsd?
U mnie, po odpaleniu nfsd na Slackware 12.2 demon smbd zabiera 75%
procesora.
Servant (12.07.2009, 15:58)
Olek <olotestSPAMFE> napisał(a) w wiadomosci do grupy
dyskusyjnej

> U mnie, po odpaleniu nfsd na Slackware 12.2 demon smbd zabiera 75%


To chyba nie to.
Ubiłem gada, ale to niczego nie zmieniło.
Servant (12.07.2009, 20:17)
ant <ant> napisał(a) w wiadomosci do grupy dyskusyjnej

> Ja bym wzial jeszcze pod lupe Cupsa. Swego czasu mialem
> taki zestaw samba + cups, gdzie cups lubil zdychac
> i tez siadac na procku. Wymienilem cupsa na nowszego
> i zaczelo dzialac.


CUPSa mam skompilowanego własnoręcznie.
Paczka zrobiona checkinstalem.
Niestety, grzebałem w kodzie bo ta wersja (1.3.5) nie chciała współpracować z
samba z ustawionym kodowaniem ISO8859-2
Przyjrzałem sie źródłom i okazało się, że w przeciwieństwie do wcześniejszych
wersji, ta ma tylko obsługę kodowania UTF-8
Co zrobiłem?
Zmieniłem "po chamsku" UTF-8 na ISO8859-2, skompilowałem, zrobiłem paczkę i
zadziałało. Może jednak coś go boli...

> Na koncówkach (domyslam sie Windows) wlaczone masz
> "automatycznego wyszukiwanie folder˘w sieciowych i drukarek"


No właśnie, też staram się to wszędzie wyłączać, ale głowy nie dam, że gdzieś
się nie uchowało.

Okazało się, że starsza wersja samby też się zachowuje tak samo źle. Wróciłem
do 3.2.5
Zainstalowałem tez CUPSa 1.3.10 z paczki. Niestety, samba nie zadziałała.
Znalazłem się w punkcie wyjścia.
Servant (12.07.2009, 20:20)
Sebastian Sawicki <forlist> napisał(a) w wiadomosci do grupy
dyskusyjnej

>> Co mozna z tym zrobic?

> strace -p 29575


Żebym to jeszcze umiał coś z tego wyczytać...
Olek (13.07.2009, 09:08)
Servant pisze:
>> U mnie, po odpaleniu nfsd na Slackware 12.2 demon smbd zabiera 75%

> To chyba nie to.
> Ubiłem gada, ale to niczego nie zmieniło.


Ja musiałem ubić smbd.
Po restarcie Samby wszystko pracuje poprawnie, mimo odpalonego nfsd.
Servant (13.07.2009, 11:03)
Olek <olotestSPAMFE> napisał(a) w wiadomosci do
grupy dyskusyjnej

> Ja musiałem ubić smbd.
> Po restarcie Samby wszystko pracuje poprawnie, mimo
> odpalonego nfsd.

Bawiłem się trochę w niedzielę, instalowałem różne wersje cupsa.
Sambe restartowałem kilkukrotnie.
Objaw jest dość ciekawy: Jak nikt nie jest zalogowany, to nobody
praktycznie jest bezczynny. Jeśli zaloguje sie jeden użytkownik
(bez znaczenia który), nobody juz wykazuje aktywność rzędu 3-5%
Jak ten użytkownik otworzy ok 100 plików, to nobody potrafi już
zeżreć 15% proca. CUPS przy tej okazji też 7-10%.
Mam w planie jeszcze jakiegoś starego cupsa zainstalować, ale nie
wiem czy mi samby nie wywali. Chyba poczekam z tym do godz. 15.
Sebastian Sawicki (13.07.2009, 14:45)
Servant said the following on 12.07.2009 20:20:
> Sebastian Sawicki <forlist> napisał(a) w wiadomosci do grupy
> dyskusyjnej
>>> Co mozna z tym zrobic?

>> strace -p 29575

> Żebym to jeszcze umiał coś z tego wyczytać...


to wrzuc output tutaj..
S.
Servant (13.07.2009, 16:16)
Sebastian Sawicki <forlist> napisał(a) w wiadomosci
do grupy dyskusyjnej

Podobne wątki